How to install Eclipse 3.7 on Ubuntu 11.04

The Eclipse packages in Ubuntu are are very out of date. The latest version in the Ubuntu repos is 3.5.2 where as the latest version of Eclipse is 3.7. I’m posting this because Ubuntu 11.04 uses the new Unity desktop which uses overlay-scrollbars (scrolls bars that are hidden until you hover over them). For some reason Eclipse 5.3.2 doesn’t like to play nice with the overlay scrollbars, and I’d rather use the newest version anyways. With Eclipse, you can just download the tar.gz file from eclipse.org and run it no problem, but I like set things up in a cleaner fashion, so here’s how I did it.

1) Download Eclipse. I got eclipse-SDK-3.7-linux-gtk-x86_64.tar.gz

2) Extract it

tar xzf eclipse-SDK-3.7-linux-gtk-x86_64.tar.gz

Or just be lazy and Right Click > Extract Here

3) Move to /opt/ folder

mv eclipse /opt/
sudo chown -R root:root eclipse
sudo chmod -R +r eclipse

4) Create an eclipse executable in your path

sudo touch /usr/bin/eclipse
sudo chmod 755 /usr/bin/eclipse
sudo nano /usr/bin/eclipse

copy this into nano

#!/bin/sh
#export MOZILLA_FIVE_HOME="/usr/lib/mozilla/"
export ECLIPSE_HOME="/opt/eclipse"

$ECLIPSE_HOME/eclipse $*

save the file (^O = Ctrl+o) and exit nano (^X = Ctrl+x)

5) Create a gnome menu item

sudo nano /usr/share/applications/eclipse.desktop

copy this into nano

[Desktop Entry]
Encoding=UTF-8
Name=Eclipse
Comment=Eclipse IDE
Exec=eclipse
Icon=/opt/eclipse/icon.xpm
Terminal=false
Type=Application
Categories=GNOME;Application;Development;
StartupNotify=true

save and exit nano

6) Launch Eclipse for the first time

/opt/eclipse/eclipse -clean &

180 Comments on “How to install Eclipse 3.7 on Ubuntu 11.04

  1. hmfr… I just get a error 5:Syntax error: “(” unexpected

    Anyone knows why?

  2. This worked as charm, very concise instructions, thanks for posting!

  3. I’m new in Ubuntu but have used Eclipse for years. I Installed Eclipse in Ubuntu and after starting Eclipse wanted to create a java project. But I can just create a project. No Java-connections are shown. Usually I can configure Java-environment in eclipse under window-preferences. But no entries for java are available. Do you have an idea for this phenomena?

    • Which version of eclipse did you install and are you talking about Java EE? I’ll do my best to help, but you’ll probably have better luck and faster responses over at the eclipse forums.

  4. It works: installing Eclipse 3.7.2 classic edition on Ubuntu 11.04, both 32 bits.

  5. it worked perfectly!
    mine xubuntu just doesn’t recognize the command
    sudo chmod -R +r eclipse
    but it seems to work anyway.

    thanks a lot from sicily!

  6. I had to change the exec line to

    Exec=/opt/eclipse/eclipse

    or else it wouldn’t launch when I clicked it from the launch menu. It worked fine from the applications dir though.

  7. Thank you for the guidance, it worked like charm on Ubuntu 12.04.
    Learned something from this and I am sure I will use this method for other applications as well.

    Cheers

  8. This is a great adventure, I will give it a try and hoping it will work perfectly as I am very much in need of eclipse on my Ubuntu 10.04.

    Congrats!!!!!!

  9. Thank you Much! This was very easy and simple to install with your guide.

  10. thanks, nice post. best way to download the latest version of eclipse in Ubuntu

  11. Thank you for sharing. First I had to uninstall my previous version installed with the Ubuntu software center and Synaptic and then follow your guidelines.

  12. Many Many Thanks. This helped me get Eclipse with ADT and Android running on Debian 6 (64 bit) with xfce.

  13. It did work. However be sure u are using the right package. Always perform “#uname -m ” command before choosing the eclipse package (for 32 bit or 64 bit OS). I got wrong with that.

    Anyway thanks a lot.

  14. Hello,
    I’m already working with Helios, I don’t want to upgrade or uninstall this version and now i want to install Indigo. In this case how can i install the other version.? Since I already have an eclipse folder in /opt.
    Is it possible to have both Helios and Indigo versions together?? Thanks in advance.

  15. As a long time user fo Eclipse on Windows, I was excited to try it on Linux. I tried twice, unsuccessfully, to install Eclipse Indigo on Ubuntu 12.04 using Software Center. Much frustration ensued. Your instructions worked flawlessly!

    mv eclipse /opt/
    # for dense ones like me, you should now ‘cd /opt’ then:
    sudo chown -R root:root eclipse
    sudo chmod -R +r eclipse

    Thanks!!!

  16. just wondering what happens if you change the owner to root (as you are doing) and later want to upgrade some other components or plugins. Does the plugins folder goes exclusively to the user who is running eclipse or it will require root privileges to upgrade/downgrade plugins? BTW: great post!

  17. Pingback: Installation of Java 7, Netbeans 7, Eclipse Indigo in Ubuntu 12.04 | My Notes

  18. Thanks for this simple tutorial.. It worked fine however when I try to update the eclipse it says “Insufficient privileges to install this update”… Do I need to set any other permission as well.. or every time I need to start it using “sudo eclipse”

    • I think that’s a bug in Ubuntu 12.04/eclipse. I installed from the repo site and it fixed the problem. Go to Help>Install new software> then click on “Add”, name it what you want.i’m using Juno so my update address is “http://download.eclipse.org/eclipse/updates/4.2”. If you are using a different version of eclipse, replace the “4.2” with the platform you’re using.
      I don’t know if this will help you but it worked for me.

  19. Thanks a lot. Finally I could install Eclipse Indigo on Ubuntu 11.04 following your instructions.

  20. Thank you for the guidance, I am new to work in linux, and it has been a bit difficult, I live in venezuela and my mother tongue is spanish, I do apologize for the mistakes in my writing,
    I used ubuntu 11.04 and I have read in some post that I need to install java befor trying to install eclipse.
    Could you send to my mail a bit of more information and how to proceed.
    Thanks. keep up your good work.

  21. Worked even on CentOS 5.8. Thank you so much for the guidance:)

  22. Thanks alot, I wish you’d made some comments regarding what you type in the files – it works, thanks man.

    • Yes it will work fine, you obviously need to change the script to match the vs your installing, otherwise it should work fine.

  23. It worked perfectly…… Gud work……

    Thanks a lot man…

  24. Thanks for your tutorial ^_^
    It works fine with my eclipse-juno, and ubuntu-10.04

  25. Excellent. I did not undestand many ofthe steps but it worked. I am new to Linux.

    Thanks.

Leave a Reply to Sasan Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.